1. Уважаемые пользователи, Регистрация временно отлючена!
    Скрыть объявление

[Помогите] Не могу установить стиль

Тема в разделе "xenForo", создана пользователем Yoji, 24 авг 2017.

  1. Yoji

    Yoji

    Регистрация:
    17 авг 2017
    Сообщения:
    2
    Симпатии:
    0
    Всем доброй ночи! Такая проблема у меня
    Новичок в этом деле
    Хотел поставить другой стиль (Версия хенфоро - 1.5.14 и стиля - 1.5.14)
    Выдает такую ошибку:
    Fatal error: Maximum function nesting level of '100' reached, aborting! in Z:\home\test\www\library\XenForo\Template\Compiler.php on line 530
    Код:
    public function prepareSegmentsForIteration($segments)
    
        {
            if (!is_array($segments))
            {
                // likely a string (simple literal)
                $segments = array($segments);
            }
            else if (isset($segments['type']))
            {
                // a simple curly var/function
                $segments = array($segments);
            }
    
            return $segments;
        }
    Вот код оттуда
    Я уже менял значение "100" на "200", "250", "500" и результата ноль
    Помогите это исправить!
     
  2. gadgetss

    gadgetss

    Регистрация:
    24 июн 2017
    Сообщения:
    73
    Симпатии:
    10
    Здесь не вижу проблемы связанной со стилем..здесь на стороне хостинга скорее всего траблы..и то если судить по дороге это вообще денвер у вас... в общем здесь надо смотреть, а так сказать ничего не могу, никогда не сталкивался с таким.
     
  3. Yoji

    Yoji

    Регистрация:
    17 авг 2017
    Сообщения:
    2
    Симпатии:
    0
    Да, оказалась проблема в самом Денвере. На хостинге все отлично поставилось! Тему можно закрывать, спасибо)